What’s Vulnerable › Vulnerabilities
CVE-2015-5686
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-27 · updated 2026-06-17
- Weakness: CWE-352
Description
Parts of the Puppet Enterprise Console 3.x were found to be susceptible to clickjacking and CSRF (Cross-Site Request Forgery) attacks. This would allow an attacker to redirect user input to an untrusted site or hijack a user session.
Affected products
- Puppet Enterprise: from 3.0.0 before 2015.2.0 — fixed in 2015.2.0
How to fix
Upgrade to a fixed version: Puppet Enterprise 2015.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2015-5686 or the next vulnerability affects your stack