What’s Vulnerable › Vulnerabilities
CVE-2015-5707
- Severity: medium (CVSS 4.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-10-19 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the sg_start_req function in drivers/scsi/sg.c in the Linux kernel 2.6.x through 4.x before 4.1 allows local users to cause a denial of service or possibly have unspecified other impact via a large iov_count value in a write request.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04
- Debian Linux: 7.0, 8.0
- Linux kernel: from 2.6.0 before 4.1.0 — fixed in 4.1.0
- Suse Linux Enterprise Desktop: 11-sp3
- SUSE Linux Enterprise: 11-sp2, 11-sp3
How to fix
Upgrade to a fixed version: Linux kernel 4.1.0. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=451a2886b6bf90e2fb378f7c46c655450fb96e81
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=fdc81f45e9f57858da6351836507fbcf1b7583ee
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00029.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00032.html
Get alerted when CVE-2015-5707 or the next vulnerability affects your stack