What’s Vulnerable › Vulnerabilities
CVE-2015-5725
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-21 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in the offset method in the Active Record class in CodeIgniter before 2.2.4 allows remote attackers to execute arbitrary SQL commands via vectors involving the offset variable.
Affected products
- CodeIgniter4: before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: CodeIgniter4 2.2.4. Check the vendor advisory for mitigations.
References
- https://forum.codeigniter.com/thread-62743.html
- https://github.com/bcit-ci/CodeIgniter/commit/0dde92def6b9f276f05ff77abb07ead318f9ec23
- https://github.com/bcit-ci/CodeIgniter/issues/4020
- https://www.codeigniter.com/userguide2/changelog.html
- https://forum.codeigniter.com/thread-62743.html
- https://github.com/bcit-ci/CodeIgniter/commit/0dde92def6b9f276f05ff77abb07ead318f9ec23
- https://github.com/bcit-ci/CodeIgniter/issues/4020
- https://www.codeigniter.com/userguide2/changelog.html
Get alerted when CVE-2015-5725 or the next vulnerability affects your stack