What’s Vulnerable › Vulnerabilities
CVE-2015-6497
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-15 · updated 2026-06-17
- Weakness: CWE-20
Description
The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.
Affected products
- Adobe Magento Commerce: before 1.9.2.1; before 1.14.2.1 — fixed in 1.14.2.1, 1.9.2.1
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.2.1, 1.9.2.1. Check the vendor advisory for mitigations.
References
- http://blog.mindedsecurity.com/2015/09/autoloaded-file-inclusion-in-magento.html
- http://karmainsecurity.com/KIS-2015-04
- http://magento.com/security/patches/supee-6482
- http://packetstormsecurity.com/files/133544/Magento-1.9.2-File-Inclusion.html
- http://seclists.org/fulldisclosure/2015/Sep/48
- http://blog.mindedsecurity.com/2015/09/autoloaded-file-inclusion-in-magento.html
- http://karmainsecurity.com/KIS-2015-04
- http://magento.com/security/patches/supee-6482
- http://packetstormsecurity.com/files/133544/Magento-1.9.2-File-Inclusion.html
- http://seclists.org/fulldisclosure/2015/Sep/48
Get alerted when CVE-2015-6497 or the next vulnerability affects your stack