What’s Vulnerable › Vulnerabilities
CVE-2015-6502
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the console in Puppet Enterprise before 2015.2.1 allows remote attackers to inject arbitrary web script or HTML via the string parameter, related to Login Redirect.
Affected products
- Puppet Enterprise: before 2015.2.1 — fixed in 2015.2.1
How to fix
Upgrade to a fixed version: Puppet Enterprise 2015.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2015-6502 or the next vulnerability affects your stack