What’s Vulnerable › Vulnerabilities
CVE-2015-6589
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory traversal vulnerability in Kaseya Virtual System Administrator (VSA) 7.0.0.0 before 7.0.0.33, 8..0.0.0 before 8.0.0.23, 9.0.0.0 before 9.0.0.19, and 9.1.0.0 before 9.1.0.9 allows remote authenticated users to write to and execute arbitrary files due to insufficient restrictions in file paths to json.ashx.
Affected products
- Kaseya Virtual System Administrator: from 7.0.0.0 before 7.0.0.33; from 8.0.0.0 before 8.0.0.23; from 9.0.0.0 before 9.0.0.19; from 9.1.0.0 before 9.1.0.9 — fixed in 7.0.0.33, 8.0.0.23, 9.0.0.19, 9.1.0.9
How to fix
Upgrade to a fixed version: Kaseya Virtual System Administrator 7.0.0.33, 8.0.0.23, 9.0.0.19, 9.1.0.9. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/133782/Kaseya-Virtual-System-Administrator-Code-Execution-Privilege-Escalation.html
- http://www.zerodayinitiative.com/advisories/ZDI-15-450
- https://www.exploit-db.com/exploits/38351/
- https://www.securityfocus.com/bid/76838
- http://packetstormsecurity.com/files/133782/Kaseya-Virtual-System-Administrator-Code-Execution-Privilege-Escalation.html
- http://www.zerodayinitiative.com/advisories/ZDI-15-450
- https://www.exploit-db.com/exploits/38351/
- https://www.securityfocus.com/bid/76838
Get alerted when CVE-2015-6589 or the next vulnerability affects your stack