What’s Vulnerable › Vulnerabilities
CVE-2015-6764
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-06 · updated 2026-06-17
- Weakness: CWE-119
Description
The BasicJsonStringifier::SerializeJSArray function in json-stringifier.h in the JSON stringifier in Google V8, as used in Google Chrome before 47.0.2526.73, improperly loads array elements, which allows remote attackers to cause a denial of service (out-of-bounds memory access) or possibly have unspecified other impact via crafted JavaScript code.
Affected products
- Debian Linux: 8.0, 9.0
- Google Chrome: through 46.0.2490.86
- Node.js: from 4.0.0 through 4.1.2; from 4.2.0 before 4.2.3; from 5.0.0 through 5.1.1 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: Node.js 4.2.3. Check the vendor advisory for mitigations.
References
- http://googlechromereleases.blogspot.com/2015/12/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00017.html
- http://lists.opensuse.org/opensuse-updates/2016-01/msg00045.html
- http://www.debian.org/security/2015/dsa-3415
- http://www.securityfocus.com/bid/78209
- http://www.securitytracker.com/id/1034298
- https://chromium.googlesource.com/v8/v8/+/6df9a1db8c85ab63dee63879456b6027df53fabc
- https://code.google.com/p/chromium/issues/detail?id=554946
- https://codereview.chromium.org/1440223002
- https://security.gentoo.org/glsa/201603-09
- http://googlechromereleases.blogspot.com/2015/12/stable-channel-update.html
Get alerted when CVE-2015-6764 or the next vulnerability affects your stack