What’s Vulnerable › Vulnerabilities
CVE-2015-6831
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-01-19 · updated 2026-06-17
- Weakness: CWE-416
Description
Multiple use-after-free vulnerabilities in SPL in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 allow remote attackers to execute arbitrary code via vectors involving (1) ArrayObject, (2) SplObjectStorage, and (3) SplDoublyLinkedList, which are mishandled during unserialization.
Affected products
- Debian Linux: 7.0, 8.0
- PHP: before 5.4.44; from 5.5.0 before 5.5.28; from 5.6.0 before 5.6.12 — fixed in 5.4.44, 5.5.28, 5.6.12
How to fix
Upgrade to a fixed version: PHP 5.4.44, 5.5.28, 5.6.12. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2015/dsa-3344
- http://www.openwall.com/lists/oss-security/2015/08/19/3
- http://www.php.net/ChangeLog-5.php
- http://www.securityfocus.com/bid/76737
- https://bugs.php.net/bug.php?id=70155
- https://bugs.php.net/bug.php?id=70166
- https://bugs.php.net/bug.php?id=70168
- https://bugs.php.net/bug.php?id=70169
- https://security.gentoo.org/glsa/201606-10
- http://www.debian.org/security/2015/dsa-3344
- http://www.openwall.com/lists/oss-security/2015/08/19/3
- http://www.php.net/ChangeLog-5.php
Get alerted when CVE-2015-6831 or the next vulnerability affects your stack