What’s Vulnerable › Vulnerabilities
CVE-2015-6922
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 82.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-17 · updated 2026-06-17
- Weakness: CWE-287
Description
Kaseya Virtual System Administrator (VSA) 7.x before 7.0.0.33, 8.x before 8.0.0.23, 9.0 before 9.0.0.19, and 9.1 before 9.1.0.9 does not properly require authentication, which allows remote attackers to bypass authentication and (1) add an administrative account via crafted request to LocalAuth/setAccount.aspx or (2) write to and execute arbitrary files via a full pathname in the PathData parameter to ConfigTab/uploader.aspx.
Affected products
- Kaseya Virtual System Administrator: from 7.0.0.0 before 7.0.0.33; from 8.0.0.0 before 8.0.0.23; from 9.0.0.0 before 9.0.0.19; from 9.1.0.0 before 9.1.0.9 — fixed in 7.0.0.33, 8.0.0.23, 9.0.0.19, 9.1.0.9
How to fix
Upgrade to a fixed version: Kaseya Virtual System Administrator 7.0.0.33, 8.0.0.23, 9.0.0.19, 9.1.0.9. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/133782/Kaseya-Virtual-System-Administrator-Code-Execution-Privilege-Escalation.html
- http://www.zerodayinitiative.com/advisories/ZDI-15-448
- http://www.zerodayinitiative.com/advisories/ZDI-15-449
- https://helpdesk.kaseya.com/entries/96164487--Kaseya-Security-Advisory
- https://www.exploit-db.com/exploits/38351/
- http://packetstormsecurity.com/files/133782/Kaseya-Virtual-System-Administrator-Code-Execution-Privilege-Escalation.html
- http://www.zerodayinitiative.com/advisories/ZDI-15-448
- http://www.zerodayinitiative.com/advisories/ZDI-15-449
- https://helpdesk.kaseya.com/entries/96164487--Kaseya-Security-Advisory
- https://www.exploit-db.com/exploits/38351/
Get alerted when CVE-2015-6922 or the next vulnerability affects your stack