What’s Vulnerable › Vulnerabilities
CVE-2015-7294
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-09-06 · updated 2026-06-17
- Weakness: CWE-90
Description
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
Affected products
- Ldapauth-Fork Project Ldapauth-Fork: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: Ldapauth-Fork Project Ldapauth-Fork 2.3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/09/18/8
- http://www.openwall.com/lists/oss-security/2015/09/21/2
- https://github.com/vesse/node-ldapauth-fork/commit/3feea43e243698bcaeffa904a7324f4d96df60e4
- https://github.com/vesse/node-ldapauth-fork/issues/21
- http://www.openwall.com/lists/oss-security/2015/09/18/8
- http://www.openwall.com/lists/oss-security/2015/09/21/2
- https://github.com/vesse/node-ldapauth-fork/commit/3feea43e243698bcaeffa904a7324f4d96df60e4
- https://github.com/vesse/node-ldapauth-fork/issues/21
Get alerted when CVE-2015-7294 or the next vulnerability affects your stack