What’s Vulnerable › Vulnerabilities
CVE-2015-7515
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-27 · updated 2026-06-17
- Weakness: CWE-476
Description
The aiptek_probe function in drivers/input/tablet/aiptek.c in the Linux kernel before 4.4 allows physically proximate attackers to cause a denial of service (NULL pointer dereference and system crash) via a crafted USB device that lacks endpoints.
Affected products
- Linux kernel: before 4.4; 4.4-rc1, 4.4-rc2, 4.4-rc3, 4.4-rc4, 4.4-rc5, 4.4-rc6 (+2) — fixed in 4.4
How to fix
Upgrade to a fixed version: Linux kernel 4.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8e20cf2bce122ce9262d6034ee5d5b76fbb92f96
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00094.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00045.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00038.html
- http://www.debian.org/security/2016/dsa-3607
- http://www.securityfocus.com/bid/84288
- http://www.ubuntu.com/usn/USN-2967-1
- http://www.ubuntu.com/usn/USN-2967-2
- http://www.ubuntu.com/usn/USN-2968-1
- http://www.ubuntu.com/usn/USN-2968-2
- http://www.ubuntu.com/usn/USN-2969-1
- http://www.ubuntu.com/usn/USN-2970-1
Get alerted when CVE-2015-7515 or the next vulnerability affects your stack