What’s Vulnerable › Vulnerabilities
CVE-2015-7520
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in the (1) RadioGroup and (2) CheckBoxMultipleChoice classes in Apache Wicket 1.5.x before 1.5.15, 6.x before 6.22.0, and 7.x before 7.2.0 allow remote attackers to inject arbitrary web script or HTML via a crafted "value" attribute in a <input> element.
Affected products
- Apache Software Foundation Apache Wicket: from 1.5.0 before 1.5.15; from 6.0.0 before 6.22.0; from 7.0.0 before 7.2.0 — fixed in 1.5.15, 6.22.0, 7.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 1.5.15, 6.22.0, 7.2.0. Check the vendor advisory for mitigations.
References
- http://wicket.apache.org/news/2016/03/02/cve-2015-7520.html
- http://www.securitytracker.com/id/1035166
- http://wicket.apache.org/news/2016/03/02/cve-2015-7520.html
- http://www.securitytracker.com/id/1035166
Get alerted when CVE-2015-7520 or the next vulnerability affects your stack