What’s Vulnerable › Vulnerabilities

CVE-2015-7546

Description

The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Keystone 8.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-7546 or the next vulnerability affects your stack