What’s Vulnerable › Vulnerabilities

CVE-2015-7548

Description

OpenStack Compute (Nova) before 2015.1.3 (kilo) and 12.0.x before 12.0.1 (liberty), when using libvirt to spawn instances and use_cow_images is set to false, allow remote authenticated users to read arbitrary files by overwriting an instance disk with a crafted image and requesting a snapshot.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Nova 12.0.1, 2015.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-7548 or the next vulnerability affects your stack