What’s Vulnerable › Vulnerabilities
CVE-2015-7549
- Severity: medium (CVSS 6.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-30 · updated 2026-06-17
- Weakness: CWE-476
Description
The MSI-X MMIO support in hw/pci/msix.c in QEMU (aka Quick Emulator) allows local guest OS privileged users to cause a denial of service (NULL pointer dereference and QEMU process crash) by leveraging failure to define the .write method.
Affected products
- QEMU: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: QEMU 2.5.0. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=43b11a91dd861a946b231b89b754285
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/175380.html
- http://www.debian.org/security/2016/dsa-3471
- http://www.openwall.com/lists/oss-security/2015/12/14/2
- http://www.securityfocus.com/bid/80761
- https://bugzilla.redhat.com/show_bug.cgi?id=1291137
- https://security.gentoo.org/glsa/201602-01
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=43b11a91dd861a946b231b89b754285
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/175380.html
- http://www.debian.org/security/2016/dsa-3471
- http://www.openwall.com/lists/oss-security/2015/12/14/2
- http://www.securityfocus.com/bid/80761
Get alerted when CVE-2015-7549 or the next vulnerability affects your stack