What’s Vulnerable › Vulnerabilities
CVE-2015-7559
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-306
Description
It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.
Affected products
- Apache ActiveMQ: before 5.14.5; from 5.15.0 before 5.15.5 — fixed in 5.14.5, 5.15.5
- RedHat Jboss A-Mq: 6.2.1, 6.3
- RedHat Jboss Fuse: 6.3
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.14.5, 5.15.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-7559
- https://issues.apache.org/jira/browse/AMQ-6470
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-7559
- https://issues.apache.org/jira/browse/AMQ-6470
Get alerted when CVE-2015-7559 or the next vulnerability affects your stack