What’s Vulnerable › Vulnerabilities
CVE-2015-7560
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-03-13 · updated 2026-06-17
- Weakness: CWE-284
Description
The SMB1 implementation in smbd in Samba 3.x and 4.x before 4.1.23, 4.2.x before 4.2.9, 4.3.x before 4.3.6, and 4.4.x before 4.4.0rc4 allows remote authenticated users to modify arbitrary ACLs by using a UNIX SMB1 call to create a symlink, and then using a non-UNIX SMB1 call to write to the ACL content.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- Debian Linux: 7.0, 8.0
- Samba: from 3.2.0 before 4.1.23; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.6; 4.4.0-rc1, 4.4.0-rc2, 4.4.0-rc3 — fixed in 4.1.23, 4.2.9, 4.3.6
How to fix
Upgrade to a fixed version: Samba 4.1.23, 4.2.9, 4.3.6. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178730.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178764.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/180000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00063.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00065.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00081.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00090.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00092.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00048.html
Get alerted when CVE-2015-7560 or the next vulnerability affects your stack