What’s Vulnerable › Vulnerabilities
CVE-2015-7613
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-10-19 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in the IPC object implementation in the Linux kernel through 4.2.3 allows local users to gain privileges by triggering an ipc_addid call that leads to uid and gid comparisons against uninitialized data, related to msg.c, shm.c, and util.c.
Affected products
- Linux kernel: before 3.2.72; from 3.3 before 3.4.111; from 3.5 before 3.10.91; from 3.11 before 3.12.50; from 3.13 before 3.14.55; from 3.15 before 3.16.35 — fixed in 3.10.91, 3.12.50, 3.14.55, 3.16.35, 3.18.23, 3.2.72
How to fix
Upgrade to a fixed version: Linux kernel 3.10.91, 3.12.50, 3.14.55, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b9a532277938798b53178d5a66af6e2915cb27cf
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00029.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00032.html
- http://rhn.redhat.com/errata/RHSA-2015-2636.html
- http://www.debian.org/security/2015/dsa-3372
- http://www.openwall.com/lists/oss-security/2015/10/01/8
Get alerted when CVE-2015-7613 or the next vulnerability affects your stack