What’s Vulnerable › Vulnerabilities

CVE-2015-7691

Description

The crypto_xmit function in ntpd in NTP 4.2.x before 4.2.8p4, and 4.3.x before 4.3.77 allows remote attackers to cause a denial of service (crash) via crafted packets containing particular autokey operations. NOTE: This vulnerability exists due to an incomplete fix for CVE-2014-9750.

Affected products

How to fix

Upgrade to a fixed version: NTP 4.2.8, 4.3.77. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-7691 or the next vulnerability affects your stack