What’s Vulnerable › Vulnerabilities
CVE-2015-7705
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-07 · updated 2026-06-17
- Weakness: CWE-20
Description
The rate limiting feature in NTP 4.x before 4.2.8p4 and 4.3.x before 4.3.77 allows remote attackers to have unspecified impact via a large number of crafted requests.
Affected products
- Citrix XenServer: 6.0.2, 6.2.0, 6.5, 7.0
- Clustered Data ONTAP: all versions
- NetApp Data ONTAP operating in 7-Mode: all versions
- NetApp Oncommand Performance Manager: all versions
- NetApp OnCommand Unified Manager for 7-Mode (core package): all versions
- NTP: from 4.2.0 before 4.2.8; from 4.3.0 before 4.3.77; 4.2.8, 4.2.8-p1, 4.2.8-p1-beta1, 4.2.8-p1-beta2, 4.2.8-p1-beta3, 4.2.8-p1-beta4 (+11) — fixed in 4.2.8, 4.3.77
- Siemens Tim 4R-Ie Dnp3 Firmware: all versions
- Siemens Tim 4R-Ie Firmware: all versions
How to fix
Upgrade to a fixed version: NTP 4.2.8, 4.3.77. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00048.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00042.html
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00093.html
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00114.html
- http://packetstormsecurity.com/files/134137/Slackware-Security-Advisory-ntp-Updates.html
Get alerted when CVE-2015-7705 or the next vulnerability affects your stack