What’s Vulnerable › Vulnerabilities

CVE-2015-7744

Description

wolfSSL (formerly CyaSSL) before 3.6.8 does not properly handle faults associated with the Chinese Remainder Theorem (CRT) process when allowing ephemeral key exchange without low memory optimizations on a server, which makes it easier for remote attackers to obtain private RSA keys by capturing TLS handshakes, aka a Lenstra attack.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.22, 10.1.9, 5.5.46; wolfSSL 3.6.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-7744 or the next vulnerability affects your stack