What’s Vulnerable › Vulnerabilities

CVE-2015-7854

Description

Buffer overflow in the password management functionality in NTP 4.2.x before 4.2.8p4, and 4.3.x before 4.3.77 allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted key file.

Affected products

How to fix

Upgrade to a fixed version: NTP 4.2.8, 4.3.77. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-7854 or the next vulnerability affects your stack