What’s Vulnerable › Vulnerabilities
CVE-2015-7869
- Severity: medium (CVSS 6.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-11-24 · updated 2026-06-17
- Weakness: CWE-189
Description
Multiple integer overflows in the kernel mode driver for the NVIDIA GPU graphics driver R340 before 341.92, R352 before 354.35, and R358 before 358.87 on Windows and R304 before 304.131, R340 before 340.96, R352 before 352.63, and R358 before 358.16 on Linux allow local users to obtain sensitive information, cause a denial of service (crash), or possibly gain privileges via unknown vectors, which trigger uninitialized or out of bounds memory access. NOTE: this identifier has been SPLIT per ADT2 and ADT3 due to different vulnerability type and affected versions. See CVE-2015-8328 for the vulnerability in the NVAPI support layer in NVIDIA drivers for Windows.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Nvidia Corporation GPU Display Driver: from 304 before 304.131; from 340 before 340.96; from 352 before 352.63; from 358 before 358.16; from 340 before 341.96; from 352 before 354.35 — fixed in 304.131, 340.96, 341.96, 352.63, 354.35, 358.16
How to fix
Upgrade to a fixed version: Nvidia Corporation GPU Display Driver 304.131, 340.96, 341.96, 352.63. Check the vendor advisory for mitigations.
References
- http://nvidia.custhelp.com/app/answers/detail/a_id/3808/kw/security
- http://securitytracker.com/id/1034176
- http://ubuntu.com/usn/usn-2814-1
- https://h20565.www2.hp.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04971867
- http://nvidia.custhelp.com/app/answers/detail/a_id/3808/kw/security
- http://securitytracker.com/id/1034176
- http://ubuntu.com/usn/usn-2814-1
- https://h20565.www2.hp.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04971867
Get alerted when CVE-2015-7869 or the next vulnerability affects your stack