What’s Vulnerable › Vulnerabilities
CVE-2015-7984
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-11-19 · updated 2026-06-17
- Weakness: CWE-352
Description
Multiple cross-site request forgery (CSRF) vulnerabilities in Horde before 5.2.8, Horde Groupware before 5.2.11, and Horde Groupware Webmail Edition before 5.2.11 allow remote attackers to hijack the authentication of administrators for requests that execute arbitrary (1) commands via the cmd parameter to admin/cmdshell.php, (2) SQL queries via the sql parameter to admin/sqlshell.php, or (3) PHP code via the php parameter to admin/phpshell.php.
Affected products
- Debian Linux: 8.0
- Horde Groupware: from 5.0.0 before 5.2.11 — fixed in 5.2.11
- Horde Application Framework: from 5.0.0 before 5.2.8 — fixed in 5.2.8
How to fix
Upgrade to a fixed version: Horde Groupware 5.2.11; Horde Application Framework 5.2.8. Check the vendor advisory for mitigations.
References
- http://lists.horde.org/archives/announce/2015/001124.html
- http://lists.horde.org/archives/announce/2015/001137.html
- http://lists.horde.org/archives/announce/2015/001138.html
- http://www.debian.org/security/2015/dsa-3391
- https://www.exploit-db.com/exploits/38765/
- https://www.htbridge.com/advisory/HTB23272
- http://lists.horde.org/archives/announce/2015/001124.html
- http://lists.horde.org/archives/announce/2015/001137.html
- http://lists.horde.org/archives/announce/2015/001138.html
- http://www.debian.org/security/2015/dsa-3391
- https://www.exploit-db.com/exploits/38765/
- https://www.htbridge.com/advisory/HTB23272
Get alerted when CVE-2015-7984 or the next vulnerability affects your stack