What’s Vulnerable › Vulnerabilities
CVE-2015-8008
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-29 · updated 2026-06-17
- Weakness: CWE-284
Description
The OAuth extension for MediaWiki improperly negotiates a new client token only over Special:OAuth/initiate, which allows attackers to bypass intended IP address access restrictions by making an API request with an existing token.
Affected products
- Fedoraproject Fedora: 21, 22, 23
- Wikimedia Foundation MediaWiki: before 1.25.3 — fixed in 1.25.3
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.25.3. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/170961.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/170979.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171007.html
- http://www.openwall.com/lists/oss-security/2015/10/29/14
- http://www.securityfocus.com/bid/77379
- http://www.securitytracker.com/id/1034028
- https://bugzilla.redhat.com/show_bug.cgi?id=1273353
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2015-October/000182.html
- https://phabricator.wikimedia.org/T103022
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/170961.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/170979.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171007.html
Get alerted when CVE-2015-8008 or the next vulnerability affects your stack