What’s Vulnerable › Vulnerabilities
CVE-2015-8012
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-617
Description
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
Affected products
- lldpd: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: lldpd 0.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/10/18/2
- http://www.openwall.com/lists/oss-security/2015/10/30/2
- https://github.com/vincentbernat/lldpd/commit/793526f8884455f43daecd0a2c46772388417a00
- https://github.com/vincentbernat/lldpd/commit/9221b5c249f9e4843f77c7f888d5705348d179c0
- http://www.openwall.com/lists/oss-security/2015/10/18/2
- http://www.openwall.com/lists/oss-security/2015/10/30/2
- https://github.com/vincentbernat/lldpd/commit/793526f8884455f43daecd0a2c46772388417a00
- https://github.com/vincentbernat/lldpd/commit/9221b5c249f9e4843f77c7f888d5705348d179c0
Get alerted when CVE-2015-8012 or the next vulnerability affects your stack