What’s Vulnerable › Vulnerabilities
CVE-2015-8080
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-13 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the getnum function in lua_struct.c in Redis 2.8.x before 2.8.24 and 3.0.x before 3.0.6 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow.
Affected products
- Debian Linux: 8.0, 9.0
- openSUSE Leap: 42.1
- Opensuse: 13.2
- OpenStack: 6.0, 7.0
- Redis Labs Redis: from 2.8.0 before 2.8.24; from 3.0.0 before 3.0.6; from 5.0.0 before 5.0.8 — fixed in 2.8.24, 3.0.6, 5.0.8
How to fix
Upgrade to a fixed version: Redis Labs Redis 2.8.24, 3.0.6, 5.0.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00126.html
- http://rhn.redhat.com/errata/RHSA-2016-0095.html
- http://rhn.redhat.com/errata/RHSA-2016-0096.html
- http://rhn.redhat.com/errata/RHSA-2016-0097.html
- http://www.debian.org/security/2015/dsa-3412
- http://www.openwall.com/lists/oss-security/2015/11/06/2
- http://www.openwall.com/lists/oss-security/2015/11/06/4
- http://www.securityfocus.com/bid/77507
- https://github.com/antirez/redis/issues/2855
- https://raw.githubusercontent.com/antirez/redis/2.8/00-RELEASENOTES
- https://raw.githubusercontent.com/antirez/redis/3.0/00-RELEASENOTES
- https://security.gentoo.org/glsa/201702-16
Get alerted when CVE-2015-8080 or the next vulnerability affects your stack