What’s Vulnerable › Vulnerabilities

CVE-2015-8126

Description

Multiple buffer overflows in the (1) png_set_PLTE and (2) png_get_PLTE functions in libpng before 1.0.64, 1.1.x and 1.2.x before 1.2.54, 1.3.x and 1.4.x before 1.4.17, 1.5.x before 1.5.24, and 1.6.x before 1.6.19 allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image.

Affected products

How to fix

Upgrade to a fixed version: macOS 10.11.4; pnggroup libpng 1.0.64, 1.2.54, 1.4.17, 1.5.24. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8126 or the next vulnerability affects your stack