What’s Vulnerable › Vulnerabilities
CVE-2015-8314
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-12 · updated 2026-06-17
- Weakness: CWE-312
Description
The Devise gem before 3.5.4 for Ruby mishandles Remember Me cookies for sessions, which may allow an adversary to obtain unauthorized persistent application access.
Affected products
- heartcombo devise: before 3.5.4 — fixed in 3.5.4
How to fix
Upgrade to a fixed version: heartcombo devise 3.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-746g-3gfp-hfhw
- https://github.com/heartcombo/devise/commit/c92996646aba2d25b2c3e235fe0c4f1a84b70d24
- https://rubysec.com/advisories/CVE-2015-8314/
- https://github.com/advisories/GHSA-746g-3gfp-hfhw
- https://github.com/heartcombo/devise/commit/c92996646aba2d25b2c3e235fe0c4f1a84b70d24
- https://rubysec.com/advisories/CVE-2015-8314/
Get alerted when CVE-2015-8314 or the next vulnerability affects your stack