What’s Vulnerable › Vulnerabilities
CVE-2015-8315
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-01-23 · updated 2026-06-17
- Weakness: CWE-1333
Description
The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
Affected products
- vercel ms: before 0.7.1 — fixed in 0.7.1
How to fix
Upgrade to a fixed version: vercel ms 0.7.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96389
- https://nodesecurity.io/advisories/46
- https://support.f5.com/csp/article/K46337613?utm_source=f5support&%3Butm_medium=RSS
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96389
- https://nodesecurity.io/advisories/46
- https://support.f5.com/csp/article/K46337613?utm_source=f5support&%3Butm_medium=RSS
Get alerted when CVE-2015-8315 or the next vulnerability affects your stack