What’s Vulnerable › Vulnerabilities
CVE-2015-8366
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-14 · updated 2026-06-17
- Weakness: CWE-129
Description
Array index error in smal_decode_segment function in LibRaw before 0.17.1 allows context-dependent attackers to cause memory errors and possibly execute arbitrary code via vectors related to indexes.
Affected products
- LibRaw: before 0.17.1 — fixed in 0.17.1
How to fix
Upgrade to a fixed version: LibRaw 0.17.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/134573/LibRaw-0.17-Overflow.html
- http://seclists.org/fulldisclosure/2015/Nov/108
- http://www.libraw.org/news/libraw-0-17-1
- http://packetstormsecurity.com/files/134573/LibRaw-0.17-Overflow.html
- http://seclists.org/fulldisclosure/2015/Nov/108
- http://www.libraw.org/news/libraw-0-17-1
Get alerted when CVE-2015-8366 or the next vulnerability affects your stack