What’s Vulnerable › Vulnerabilities
CVE-2015-8367
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-14 · updated 2026-06-17
- Weakness: CWE-665
Description
The phase_one_correct function in Libraw before 0.17.1 allows attackers to cause memory errors and possibly execute arbitrary code, related to memory object initialization.
Affected products
- LibRaw: before 0.17.1 — fixed in 0.17.1
How to fix
Upgrade to a fixed version: LibRaw 0.17.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/134573/LibRaw-0.17-Overflow.html
- http://seclists.org/fulldisclosure/2015/Nov/108
- http://www.libraw.org/news/libraw-0-17-1
- http://packetstormsecurity.com/files/134573/LibRaw-0.17-Overflow.html
- http://seclists.org/fulldisclosure/2015/Nov/108
- http://www.libraw.org/news/libraw-0-17-1
Get alerted when CVE-2015-8367 or the next vulnerability affects your stack