What’s Vulnerable › Vulnerabilities

CVE-2015-8386

Description

PCRE before 8.38 mishandles the interaction of lookbehind assertions and mutually recursive subpatterns, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.32, 5.6.18, 7.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8386 or the next vulnerability affects your stack