What’s Vulnerable › Vulnerabilities
CVE-2015-8391
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-02 · updated 2026-06-17
- Weakness: CWE-119
Description
The pcre_compile function in pcre_compile.c in PCRE before 8.38 mishandles certain [: nesting, which allows remote attackers to cause a denial of service (CPU consumption) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.
Affected products
- Fedoraproject Fedora: 22
- Oracle Corporation Oracle Linux: 7
- Pcre: before 8.38 — fixed in 8.38
- PHP: from 5.5.0 before 5.5.32; from 5.6.0 before 5.6.18; from 7.0.0 before 7.0.3 — fixed in 5.5.32, 5.6.18, 7.0.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.2, 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Pcre 8.38; PHP 5.5.32, 5.6.18, 7.0.3. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/174931.html
- http://rhn.redhat.com/errata/RHSA-2016-1025.html
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://vcs.pcre.org/pcre/code/trunk/ChangeLog?view=markup
- http://www-01.ibm.com/support/docview.wss?uid=isg3T1023886
- http://www.openwall.com/lists/oss-security/2015/11/29/1
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://www.securityfocus.com/bid/82990
- https://access.redhat.com/errata/RHSA-2016:1132
- https://bto.bluecoat.com/security-advisory/sa128
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731
- https://security.gentoo.org/glsa/201607-02
Get alerted when CVE-2015-8391 or the next vulnerability affects your stack