What’s Vulnerable › Vulnerabilities

CVE-2015-8393

Description

pcregrep in PCRE before 8.38 mishandles the -q option for binary files, which might allow remote attackers to obtain sensitive information via a crafted file, as demonstrated by a CGI script that sends stdout data to a client.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.32, 5.6.18, 7.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8393 or the next vulnerability affects your stack