What’s Vulnerable › Vulnerabilities

CVE-2015-8394

Description

PCRE before 8.38 mishandles the (?(<digits>) and (?(R<digits>) conditions, which allows remote attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.32, 5.6.18, 7.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8394 or the next vulnerability affects your stack