What’s Vulnerable › Vulnerabilities

CVE-2015-8530

Description

Stack-based buffer overflow in the Initialize function in an ActiveX control in IBM SPSS Statistics 19 and 20 before 20.0.0.2-IF0008, 21 before 21.0.0.2-IF0010, 22 before 22.0.0.2-IF0011, 23 before 23.0.0.3-IF0001, and 24 before 24.0.0.0-IF0003 allows remote authenticated users to execute arbitrary code via a long argument.

Affected products

How to fix

Upgrade to a fixed version: IBM SPSS Statistics 20.0.0.2, 21.0.0.2, 22.0.0.2, 23.0.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8530 or the next vulnerability affects your stack