What’s Vulnerable › Vulnerabilities
CVE-2015-8651: Adobe Flash Player Integer Overflow Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-05-25
- EPSS: 67.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-28 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before 20.0.0.267 on Windows and OS X and before 11.2.202.559 on Linux, Adobe AIR before 20.0.0.233, Adobe AIR SDK before 20.0.0.233, and Adobe AIR SDK & Compiler before 20.0.0.233 allows attackers to execute arbitrary code via unspecified vectors.
Affected products
- Adobe Air: before 20.0.0.233 — fixed in 20.0.0.233
- Adobe Air Sdk: before 20.0.0.233 — fixed in 20.0.0.233
- Adobe Air Sdk & Compiler: before 20.0.0.233 — fixed in 20.0.0.233
- Adobe Flash Player 24.0.0.186 and earlier.: before 11.2.202.559; before 18.0.0.324; from 19.0.0.185 before 20.0.0.267 — fixed in 11.2.202.559, 18.0.0.324, 20.0.0.267
- Hewlett Packard Enterprise Insight Control: before 7.6 — fixed in 7.6
- HP Insight Control Server Provisioning: before 7.6 — fixed in 7.6
- Hewlett Packard Enterprise Matrix Operating Environment: 7.6
- Hewlett Packard Enterprise System Management Homepage for Windows and Linux: before 7.6 — fixed in 7.6
- Hewlett Packard Enterprise Systems Insight Manager using OpenSSL: before 7.6 — fixed in 7.6
- Hewlett Packard Enterprise Version Control Repository Manager (VCRM): before 7.6 — fixed in 7.6
- openSUSE Evergreen: 11.4
- Opensuse: 13.1, 13.2
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- SUSE Linux Enterprise Server 15 SP1: 11-sp3, 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise Workstation Extension: 12, 12-sp1
How to fix
Upgrade to a fixed version: Adobe Air 20.0.0.233; Adobe Air Sdk 20.0.0.233; Adobe Air Sdk & Compiler 20.0.0.233; Adobe Flash Player 24.0.0.186 and earlier. 11.2.202.559, 18.0.0.324, 20.0.0.267; Hewlett Packard Enterprise Insight Control 7.6; HP Insight Control Server Provisioning 7.6; Hewlett Packard Enterprise System Management Homepage for Windows and Linux 7.6; Hewlett Packard Enterprise Systems Insight Manager using OpenSSL 7.6; Hewlett Packard Enterprise Version Control Repository Manager (VCRM) 7.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00045.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00048.html
- http://rhn.redhat.com/errata/RHSA-2015-2697.html
- http://www.securityfocus.com/bid/79705
- http://www.securitytracker.com/id/1034544
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05356388
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05385680
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722
- https://helpx.adobe.com/security/products/flash-player/apsb16-01.html
- https://security.gentoo.org/glsa/201601-03
Get alerted when CVE-2015-8651 or the next vulnerability affects your stack