What’s Vulnerable › Vulnerabilities
CVE-2015-8806
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-13 · updated 2026-06-17
Description
dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an unexpected character immediately after the "<!DOCTYPE html" substring in a crafted HTML document.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- xmlsoft libxml2: before 2.9.4 — fixed in 2.9.4
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.9.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/02/03/5
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.securityfocus.com/bid/82071
- http://www.ubuntu.com/usn/USN-2994-1
- https://bugzilla.gnome.org/show_bug.cgi?id=749115
- https://security.gentoo.org/glsa/201701-37
- https://www.debian.org/security/2016/dsa-3593
- http://www.openwall.com/lists/oss-security/2016/02/03/5
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.securityfocus.com/bid/82071
- http://www.ubuntu.com/usn/USN-2994-1
- https://bugzilla.gnome.org/show_bug.cgi?id=749115
Get alerted when CVE-2015-8806 or the next vulnerability affects your stack