What’s Vulnerable › Vulnerabilities
CVE-2015-8816
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-27 · updated 2026-06-17
Description
The hub_activate function in drivers/usb/core/hub.c in the Linux kernel before 4.3.5 does not properly maintain a hub-interface data structure, which allows physically proximate attackers to cause a denial of service (invalid memory access and system crash) or possibly have unspecified other impact by unplugging a USB hub device.
Affected products
- Linux kernel: from 2.6.28 before 3.2.76; from 3.3 before 3.4.113; from 3.5 before 3.10.103; from 3.11 before 3.12.58; from 3.13 before 3.14.76; from 3.15 before 3.16.35 — fixed in 3.10.103, 3.12.58, 3.14.76, 3.16.35, 3.18.27, 3.2.76
- Novell Suse Linux Enterprise Debuginfo: 11-sp4
- Novell Suse Linux Enterprise Desktop: 12.0
- Novell Suse Linux Enterprise Live Patching: 12.0
- Novell Suse Linux Enterprise Module For Public Cloud: 12
- Novell Suse Linux Enterprise Real Time Extension: 11-sp4, 12-sp1
- Novell Suse Linux Enterprise Server: 11-extra, 11-sp4, 12.0
- Novell Suse Linux Enterprise Software Development Kit: 11.0-sp4, 12.0
- Novell Suse Linux Enterprise Workstation Extension: 12.0
- SUSE Linux Enterprise Live Patching: 12
- SUSE Linux Enterprise Server: 12
How to fix
Upgrade to a fixed version: Linux kernel 3.10.103, 3.12.58, 3.14.76, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=e50293ef9775c5f1cf3fcc093037dd6a8c5684ea
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00018.html
Get alerted when CVE-2015-8816 or the next vulnerability affects your stack