What’s Vulnerable › Vulnerabilities
CVE-2015-8851
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-30 · updated 2026-10-07
- Weakness: CWE-331
Description
node-uuid before 1.4.4 uses insufficiently random data to create a GUID, which could make it easier for attackers to have unspecified impact via brute force guessing.
Affected products
- node-uuid: before 1.4.4 — fixed in 1.4.4
How to fix
Upgrade to a fixed version: node-uuid 1.4.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/04/13/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1327056
- https://github.com/broofa/node-uuid/commit/672f3834ed02c798aa021c618d0a5666c8da000d
- https://nodesecurity.io/advisories/93
- http://www.openwall.com/lists/oss-security/2016/04/13/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1327056
- https://github.com/broofa/node-uuid/commit/672f3834ed02c798aa021c618d0a5666c8da000d
- https://nodesecurity.io/advisories/93
Get alerted when CVE-2015-8851 or the next vulnerability affects your stack