What’s Vulnerable › Vulnerabilities
CVE-2015-8857
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-01-23 · updated 2026-06-17
- Weakness: CWE-254
Description
The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.
Affected products
- Uglifyjs Project Uglifyjs: before 2.4.24 — fixed in 2.4.24
How to fix
Upgrade to a fixed version: Uglifyjs Project Uglifyjs 2.4.24. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96410
- https://nodesecurity.io/advisories/39
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96410
- https://nodesecurity.io/advisories/39
Get alerted when CVE-2015-8857 or the next vulnerability affects your stack