What’s Vulnerable › Vulnerabilities
CVE-2015-8861
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The handlebars package before 4.0.0 for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging a template with an attribute that is not quoted.
Affected products
- Handlebars.Js Project Handlebars.Js: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Handlebars.Js Project Handlebars.Js 4.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96434
- https://www.sourceclear.com/blog/handlebars_vulnerability_research_findings/
- https://www.tenable.com/security/tns-2016-18
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- http://www.securityfocus.com/bid/96434
- https://www.sourceclear.com/blog/handlebars_vulnerability_research_findings/
- https://www.tenable.com/security/tns-2016-18
Get alerted when CVE-2015-8861 or the next vulnerability affects your stack