What’s Vulnerable › Vulnerabilities
CVE-2015-8866
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-05-22 · updated 2026-06-17
- Weakness: CWE-611
Description
ext/libxml/libxml.c in PHP before 5.5.22 and 5.6.x before 5.6.6, when PHP-FPM is used, does not isolate each thread from libxml_disable_entity_loader changes in other threads, which allows remote attackers to conduct XML External Entity (XXE) and XML Entity Expansion (XEE) attacks via a crafted XML document, a related issue to CVE-2015-5161.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- openSUSE Leap: 42.1
- Opensuse: 13.2
- PHP: from 5.5.0 before 5.5.22; from 5.6.0 before 5.6.6; from 7.0.0 before 7.0.27; from 7.1.0 before 7.1.13; from 7.2.0 before 7.2.1 — fixed in 5.5.22, 5.6.6, 7.0.27, 7.1.13, 7.2.1
- SUSE Linux Enterprise Module For Web Scripting: 12
- SUSE Linux Enterprise Software Development Kit: 12, 12-sp1
How to fix
Upgrade to a fixed version: PHP 5.5.22, 5.6.6, 7.0.27, 7.1.13. Check the vendor advisory for mitigations.
References
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=de31324c221c1791b26350ba106cc26bad23ace9
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00056.html
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://www.openwall.com/lists/oss-security/2016/04/24/1
- http://www.php.net/ChangeLog-5.php
- http://www.securityfocus.com/bid/87470
- http://www.ubuntu.com/usn/USN-2952-1
- http://www.ubuntu.com/usn/USN-2952-2
- https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1509817
- https://bugs.php.net/bug.php?id=64938
Get alerted when CVE-2015-8866 or the next vulnerability affects your stack