What’s Vulnerable › Vulnerabilities
CVE-2015-8867
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-05-22 · updated 2026-06-17
- Weakness: CWE-310
Description
The openssl_random_pseudo_bytes function in ext/openssl/openssl.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 incorrectly relies on the deprecated RAND_pseudo_bytes function, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- PHP: from 5.4.0 before 5.4.44; from 5.5.0 before 5.5.28; from 5.6.0 before 5.6.12 — fixed in 5.4.44, 5.5.28, 5.6.12
How to fix
Upgrade to a fixed version: PHP 5.4.44, 5.5.28, 5.6.12. Check the vendor advisory for mitigations.
References
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=16023f3e3b9c06cf677c3c980e8d574e4c162827
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00056.html
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://www.openwall.com/lists/oss-security/2016/04/24/1
- http://www.php.net/ChangeLog-5.php
- http://www.php.net/ChangeLog-7.php
- http://www.ubuntu.com/usn/USN-2952-1
- http://www.ubuntu.com/usn/USN-2952-2
- https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1534203
- https://bugs.php.net/bug.php?id=70014
Get alerted when CVE-2015-8867 or the next vulnerability affects your stack