What’s Vulnerable › Vulnerabilities
CVE-2015-8873
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-05-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Stack consumption vulnerability in Zend/zend_exceptions.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 allows remote attackers to cause a denial of service (segmentation fault) via recursive method calls.
Affected products
- openSUSE Leap: 42.1
- PHP: before 5.4.44; from 5.5.0 before 5.5.28; from 5.6.0 before 5.6.12 — fixed in 5.4.44, 5.5.28, 5.6.12
How to fix
Upgrade to a fixed version: PHP 5.4.44, 5.5.28, 5.6.12. Check the vendor advisory for mitigations.
References
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=4d2278143a08b7522de9471d0f014d7357c28fea
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00027.html
- http://php.net/ChangeLog-5.php
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- https://bugs.php.net/bug.php?id=69793
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=4d2278143a08b7522de9471d0f014d7357c28fea
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00027.html
- http://php.net/ChangeLog-5.php
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- https://bugs.php.net/bug.php?id=69793
Get alerted when CVE-2015-8873 or the next vulnerability affects your stack