What’s Vulnerable › Vulnerabilities

CVE-2015-8876

Description

Zend/zend_exceptions.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 does not validate certain Exception objects, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) or trigger unintended method execution via crafted serialized data.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.44, 5.5.28, 5.6.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8876 or the next vulnerability affects your stack