What’s Vulnerable › Vulnerabilities

CVE-2015-8878

Description

main/php_open_temporary_file.c in PHP before 5.5.28 and 5.6.x before 5.6.12 does not ensure thread safety, which allows remote attackers to cause a denial of service (race condition and heap memory corruption) by leveraging an application that performs many temporary-file accesses.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.28, 5.6.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8878 or the next vulnerability affects your stack