What’s Vulnerable › Vulnerabilities

CVE-2015-8962

Description

Double free vulnerability in the sg_common_write function in drivers/scsi/sg.c in the Linux kernel before 4.4 allows local users to gain privileges or cause a denial of service (memory corruption and system crash) by detaching a device during an SG_IO ioctl call.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.70, 3.16.40, 3.18.54. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-8962 or the next vulnerability affects your stack