What’s Vulnerable › Vulnerabilities
CVE-2015-8968
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-11-03 · updated 2026-06-17
- Weakness: CWE-77
Description
git-fastclone before 1.0.1 permits arbitrary shell command execution from .gitmodules. If an attacker can instruct a user to run a recursive clone from a repository they control, they can get a client to run an arbitrary shell command. Alternately, if an attacker can MITM an unencrypted git clone, they could exploit this. The ext command will be run if the repository is recursively cloned or if submodules are updated. This attack works when cloning both local and remote repositories.
Affected products
- git-fastclone ruby gem All versions before 1.0.1: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: git-fastclone ruby gem All versions before 1.0.1 1.0.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/81433
- https://github.com/square/git-fastclone/pull/2
- https://hackerone.com/reports/104465
- http://www.securityfocus.com/bid/81433
- https://github.com/square/git-fastclone/pull/2
- https://hackerone.com/reports/104465
Get alerted when CVE-2015-8968 or the next vulnerability affects your stack